Habilitar o upgrade automático do Wordpress

Os desenvolvedores do Wordpress inseriram um recurso interessante na versão 3.7 de seu software - atualizações automáticas - porém, o mesmo não faz o upgrade do software para as chamadas "major releases" (que poderíamos considerar como mudança de dígito - ex.: mudar da versão 3.7 para a 3.8).


Para habilitar este recurso, basta editar a linha wp-config.php, que encontra-se na pasta raiz do app, e adicionar o código abaixo logo após a última linha do arquivo. Salve e pronto!

define( ‘WP_AUTO_UPDATE_CORE’, true );

A linha acima também fará atualizações para os "nightly builds", que podem não ser tão estáveis. Para fazer com que o software apenas seja atualizado para as versões finais, edite o arquivo "function.php" presente em seu tema e adicione a linha abaixo (o caminho do function.php deve ser equivalemte a /wp-content/themes/SeuTema/function.php):

add_filter( ‘allow_dev_auto_core_updates’, ‘__return_false’ );
Habilitar o upgrade automático do Wordpress Habilitar o upgrade automático do Wordpress Reviewed by Marcos Garcia on novembro 04, 2013 Rating: 5

Nenhum comentário:

Tecnologia do Blogger.